Beberapa Kelemahan Eksekusi Kode Ditemukan Dalam Bahasa Pemrograman PHP

Diterbitkan dalam 2019-09-07  153 Membaca


Pemelihara bahasa pemrograman PHP baru-baru ini merilis versi terbaru PHP untuk menambal beberapa kerentanan tingkat tinggi di perpustakaan inti dan bundelnya, yang paling parah dapat memungkinkan penyerang jarak jauh untuk mengeksekusi kode arbitrer dan kompromi server yang ditargetkan. Hypertext Preprocessor, umumnya dikenal sebagai PHP, adalah bahasa pemrograman web sisi server paling populer yang menggerakkan lebih dari 78 persen Internet saat ini. Rilis terbaru di bawah beberapa cabang yang dikelola termasuk PHP versi 7.3.9, 7.2.22 dan 7.1.32, menangani beberapa kerentanan keamanan. Bergantung pada jenis, kejadian, dan penggunaan basis kode yang terpengaruh dalam aplikasi PHP, eksploitasi yang berhasil dari beberapa kerentanan paling parah dapat memungkinkan penyerang untuk mengeksekusi kode arbitrer dalam konteks aplikasi yang terpengaruh dengan hak istimewa terkait.

Selain itu, upaya gagal eksploitasi kemungkinan akan menghasilkan kondisi penolakan layanan (DoS) pada sistem yang terpengaruh.
Kerentanan dapat meninggalkan ratusan ribu aplikasi web yang bergantung pada PHP terbuka untuk serangan eksekusi kode, termasuk situs web yang didukung oleh beberapa sistem manajemen konten populer seperti WordPress, Drupal dan Typo3.

Dari ini, kerentanan eksekusi kode 'use-after-free', ditetapkan sebagai CVE-2019-13224, berada di Oniguruma, perpustakaan ekspresi reguler populer yang dibundel dengan PHP, serta banyak bahasa pemrograman lainnya. Penyerang jarak jauh dapat mengeksploitasi kelemahan ini dengan memasukkan ekspresi reguler yang dibuat khusus dalam aplikasi web yang terpengaruh, berpotensi mengarah pada eksekusi kode atau menyebabkan pengungkapan informasi.

"Penyerang menyediakan sepasang pola regex dan string, dengan pengkodean multi-byte yang ditangani oleh onig_new_deluxe ()," kata Red Hat dalam penasehat keamanannya yang menjelaskan kerentanan.
Kelemahan yang ditambal lainnya memengaruhi ekstensi keriting, fungsi Exif, FastCGI Process Manager (FPM), fitur Opcache, dan banyak lagi.
Kabar baiknya adalah sejauh ini tidak ada laporan tentang kerentanan keamanan ini yang dieksploitasi di alam bebas oleh penyerang.
Tim keamanan PHP telah membahas kerentanan dalam versi terbaru. Jadi pengguna dan penyedia hosting sangat disarankan untuk meningkatkan server mereka ke versi PHP terbaru 7.3.9, 7.2.22, atau 7.1.32.

Artikel ini didasarkan pada perjanjian internasional BY-NA-SA 4.0Berbagi kesepakatan;
Jika tidak ditentukan, artikel di situs ini adalah artikel asli, harap cetak ulang.

0

Seorang Maniak IT dan Founder dari Detroit Network